Legendary Aegitna Not Returning Back

Discussion in 'Bug Reports' started by NoteHermelin786, Aug 29, 2022.

  1. NoteHermelin786

    NoteHermelin786 Spearman

    Joined:
    Feb 19, 2021
    Messages:
    12
    Likes Received:
    6
    Trophy Points:
    3
    Hi, there seems to be a bug with the cool down timer on my Norse for this legendary quest Aegitna in Lodi.
    I thought of reporting it for a while but I wanted to wait and observe for some updates to see if it goes.
    But this is going on for months. Could someone please have a look at it.
    It is fine for my other civs.

    upload_2022-8-29_20-36-56.png

    In game name is NoteHermelin786

    Many thanks for the kind souls looking into this.
     
  2. Loading...


  3. PF2K

    PF2K Lead Developer
    Staff Member Administrator

    Joined:
    Oct 24, 2017
    Messages:
    941
    Likes Received:
    3,259
    Trophy Points:
    93
    Hi there, looking at your profile, it says that your quest is set on "Failed" status. Could you look into your quest log and see if you can abandon this quest?
     
    NoteHermelin786 likes this.
  4. NoteHermelin786

    NoteHermelin786 Spearman

    Joined:
    Feb 19, 2021
    Messages:
    12
    Likes Received:
    6
    Trophy Points:
    3
    Holy Mackerel, you are right. It is there in quest log but not in the quest giver.
    Many thanks mate for the solution

    Best regards
     
    PF2K likes this.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice