Can't go back to city quest

Discussion in 'Bug Reports' started by PintusPT, Feb 10, 2019.

  1. PintusPT

    PintusPT Villager

    Joined:
    Feb 10, 2019
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Before the last update, I was playing coop with a friend, then he left the mission and I kept looking for treasures. After 10 minutes, as I was about to leave the mission, the "return to city quest" button no longer worked, so I had to restart the game. After restarting it, it worked.

    A few days later, my friend had a similar problem during a solo mission, he couldn't click the mission as well and he had to restart the game in order for the "return to city quest" button to work.

    However, it's not working today for some reason. I was playing the solo mission where you help a neighbour's city, and right after I concluded all the objectives, I pressed the "return to city quest" mission, but without success. I proceeded to press the "golden icon" with a house and I went back to my town, but as I clicked the map icon again, the "return to city quest" button wasn't working (again). I restarted the game and tried it again, but it doesn't work. I restarted it a second time, and it's still not working. If it doesn't work for a third time, I will abandon the quest and repeat it. If it still doesn't work after it, I will update this post.

    By the way, when I pressed the golden house icon, all the advisors disappeared from my town, only citizens could be seen walking around. After restarting, they appeared again, but I can't still return to the city quest, as said before. I can't add a picture from my town, this thread isn't allowing me to load the picture for some unknown reason to me.

    Edit: I tried a third time, and now the "return to city quest" button turned into "Travelling...", but it stays like this forever.

    Edit 2: I abandoned the quest and repeated the quest, it finally worked! Still, I've experienced this bug more than once, as well as other players, probably.
     

    Attached Files:

    • 1.png
      1.png
      File size:
      923 KB
      Views:
      10
    • 3.png
      3.png
      File size:
      1,005.3 KB
      Views:
      12
    • 5.png
      5.png
      File size:
      1,000.5 KB
      Views:
      13
    #1 PintusPT, Feb 10, 2019 at 9:57 PM
    Last edited: Feb 10, 2019
  2. Loading...


  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice