The event legacy buildings lost their quest givers

Discussion in 'Bug Reports' started by ConradIII, Nov 20, 2022.

  1. ConradIII

    ConradIII Woad Raider

    Joined:
    May 8, 2022
    Messages:
    31
    Likes Received:
    3
    Trophy Points:
    8
    As it states , the winter , summer, Halloween buildings that allow you to play quests have lost the quest givers
    so you cannot do the quests :(
     
  2. Loading...


  3. Slyrevick

    Slyrevick Hippikon

    Joined:
    May 22, 2020
    Messages:
    188
    Likes Received:
    72
    Trophy Points:
    28

    As a workaround,

    You may try to start the quest by visiting a capital city.
     
  4. Unknown Maniac

    Unknown Maniac Berserker

    Joined:
    Nov 9, 2019
    Messages:
    102
    Likes Received:
    60
    Trophy Points:
    28
    I can see the quest givers in both my capital and other player's city. are you sure about that? can you provide screenshots?
     
  5. Lordgarmadon

    Lordgarmadon Spearman

    Joined:
    Aug 14, 2022
    Messages:
    6
    Likes Received:
    4
    Trophy Points:
    3
    they are still there for me plus the halloween quests still give the event materials and points lol
     
  6. destroyerarcher

    destroyerarcher Champion

    Joined:
    Nov 15, 2017
    Messages:
    49
    Likes Received:
    54
    Trophy Points:
    18
    There are two ways the bug happens: One is when the game thinks you are in haunted isle but you're really kicked to your capital. This can be seen if your capital shield is replaced with the Haunted Isle shield, and can be fixed by leaving the capital then returning. It seems likely that is the bug that is happening.

    The other is that placing a building too close to the edge or another tight area can cause the questgiver to not spawn. If that happens simply move the building until the questgiver shows up.
     
  7. ConradIII

    ConradIII Woad Raider

    Joined:
    May 8, 2022
    Messages:
    31
    Likes Received:
    3
    Trophy Points:
    8
    That was it, I took your advice and fixed it. It appears I left all my civs in haunted isle and when I logged off/ on they all had the problem - but now all fixed - thanks mate
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice